Back to overview
Downtime

User Authentication, Prosci Portal, Proxima, Knowledge Hub, Research Hub, Ecommerce Store, and 4 other services are down

May 29 at 12:06am MDT
Affected services
Portal, Kaiya, Hub Tools
Proxima
Enterprise Admin Portal

Resolved
May 29 at 12:13am MDT

User Authentication, Prosci Portal, Proxima, and 3 other resources recovered.

Created
May 29 at 12:06am MDT

User Authentication, Prosci Portal, Proxima, and 3 other resources went down.